本文告诉大家在 天河2 运行程序时发现 version GLIBCXX_3.4.21 not found 如何修复

我在天河2运行一个程序报错

 version `GLIBCXX_3.4.21' not found

解决简单,在 http://ftp.de.debian.org/debian/pool/main/g 找GCC,我现在是GCC6,可以下载更改的版本,下面的链接就是 GCC6 的链接

下载:http://ftp.de.debian.org/debian/pool/main/g/gcc-6/libstdc++6_6.1.1-11_amd64.deb

http://ftp.de.debian.org/debian/pool/main/g/gcc-4.9/libstdc++6_4.9.2-10_amd64.deb

可以进入 http://ftp.de.debian.org/debian/pool/main/g/gcc-6/ 搜索libstdc++6_找到一个AMD64或I386


  ar -x libstdc++-6-dev_6.1.1-11_amd64.deb  && tar xvf data.tar.xz


本文会经常更新,请阅读原文: https://blog.lindexi.com/post/%E5%A4%A9%E6%B2%B32-%E7%A8%8B%E5%BA%8F-version-GLIBCXX_3.4.21-not-found-%E8%A7%A3%E5%86%B3%E6%96%B9%E6%B3%95.html ,以避免陈旧错误知识的误导,同时有更好的阅读体验。

如果你想持续阅读我的最新博客,请点击 RSS 订阅,推荐使用RSS Stalker订阅博客,或者前往 CSDN 关注我的主页

知识共享许可协议 本作品采用 知识共享署名-非商业性使用-相同方式共享 4.0 国际许可协议 进行许可。欢迎转载、使用、重新发布,但务必保留文章署名林德熙(包含链接: https://blog.lindexi.com ),不得用于商业目的,基于本文修改后的作品务必以相同的许可发布。如有任何疑问,请 与我联系