本文告诉大家如何修复使用 SmartAssembly 7.5 混淆 .NET 6 应用时提示 Unable to load runtime config file 失败

因为在 SmartAssembly 7.5 发布时,还没有正式发布 .NET 6 版本,好在 IL 是兼容的,因此跑起来也没有什么问题。为了让 SmartAssembly 能跑起来,只需要新建一个 Xxx.runtimeconfig.json 文件,在文件里面放入以下内容

{
  "runtimeOptions": 
  {
    "tfm": "net6.0",
    "framework": 
    {
      "name": "Microsoft.NETCore.App",
      "version": "6.0.0"
    }
  }
}

这个 Xxx.runtimeconfig.json 里的 Xxx 没啥要求,似乎写啥都行,写 Xxx 也行,只要有这个文件即可。那同文件夹下有多个 runtimeconfig 文件?没问题,放多个文件也没问题

更多请看 Failed to load assembly. Unable to load runtime config file. — Redgate forums


本文会经常更新,请阅读原文: https://blog.lindexi.com/post/%E4%BF%AE%E5%A4%8D-SmartAssembly-%E6%B7%B7%E6%B7%86-.NET-6-%E6%97%B6%E6%8F%90%E7%A4%BA-Unable-to-load-runtime-config-file-%E5%A4%B1%E8%B4%A5.html ,以避免陈旧错误知识的误导,同时有更好的阅读体验。

如果你想持续阅读我的最新博客,请点击 RSS 订阅,推荐使用RSS Stalker订阅博客,或者前往 CSDN 关注我的主页

知识共享许可协议 本作品采用 知识共享署名-非商业性使用-相同方式共享 4.0 国际许可协议 进行许可。欢迎转载、使用、重新发布,但务必保留文章署名林德熙(包含链接: https://blog.lindexi.com ),不得用于商业目的,基于本文修改后的作品务必以相同的许可发布。如有任何疑问,请 与我联系

无盈利,不卖课,做纯粹的技术博客

以下是广告时间

推荐关注 Edi.Wang 的公众号

欢迎进入 Eleven 老师组建的 .NET 社区

以上广告全是友情推广,无盈利